관리 메뉴

이사작전.com IT Blog

[해결] 윈도우에서 could not find a version that satisfies the requirement sip 에러를 고치는 방법 본문

Programming language/Python

[해결] 윈도우에서 could not find a version that satisfies the requirement sip 에러를 고치는 방법

말랑고양 플랫폼공작소 2018.10.05 18:22

안녕하세요. 말랑고양입니다. pyqt5를 설치하면서 could not find a version that satisfies the requirement sip라는 오류에 직면하였습니다. 어찌어찌 해결하였는데, 그 방법을 공유합니다. stackoverflow에 참 많은 해결방법이 논의되고 있는데요, 저는 아래의 방법으로 해결하였습니다.


1. PyQt 다운로드

https://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-5.5.1/ 저는 파이썬 3.4.4 (32bit)를 사용하고 있으므로, PyQt5-5.5.1-gpl-Py3.4-Qt5.5.1-x32.exe를 다운로드 받아서 설치하였습니다. 당연한 얘기지만, 파이썬 버전에 맞는 PyQt5를 설치하는게 좋습니다.



2. 다운받은 파일을 실행하여 설치합니다.

저의 파이썬 폴더는 C:\Python34 입니다.

때문에 PyQt5도 그 폴더에 경로를 맞춰서 설치를 하였습니다.


-- 저는 이렇게 함으로써 해결이 되었습니다.

추가로 궁금한 점이나 질문사항이 있다면 댓글남겨주세요. 감사합니다.

#PyQt5 #파이썬 #에러 #해결

0 Comments
댓글쓰기 폼